ADODB Connection to btrieve database failing in AS

Results 1 to 2 of 2

Thread: ADODB Connection to btrieve database failing in AS

  1. #1
    Join Date
    Dec 1969

    Default ADODB Connection to btrieve database failing in AS

    I&#039m currently trying to get access to a btrieve database. I have developed on my developing machine a simple asp script that accesses the demodata that comes with Pervasive SQL 7.0. Once this was working I copied the page over to the production server to test and I recieve a Catastrophic error &#039 8000ffff&#039 from the Pervasive ODBC Provider. <BR><BR>So I checked the DSN and reasured I was going against the correct DDF&#039s. I am.. I then opened SQL Server 7.0 and imported VIA the DSN a table and it worked. Hmmm..<BR><BR>I then opened up VB and created a Webclass using the same script and that failed as well if I used a server.createobject("ADODB.Connection"), but if I don&#039t use Server and run the Webclass in debug mode it works. Compiled and it fails.<BR><BR>Here is my sample script:<BR>&#060;%@ Language=VBScript %&#062;<BR>&#060;!-- #Include virtual="/Passport/Include/" --&#062;<BR>&#060;HTML&#062;<BR>&#060;HEAD&#062;<BR> &#060;META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0"&#062;<BR>&#060;/HEAD&#062;<BR>&#060;BODY&#062;<BR><BR>&#060;%<BR>d im BTVConn<BR>dim ssql<BR>dim cmdBTV<BR>dim rsBTV<BR>dim param<BR><BR>Set BTVConn = server.CreateObject("ADODB.Connection")<BR>BTVConn .Open "DSN=BTVDemo"<BR><BR>set cmdBTV = server.CreateObject("ADODB.Command")<BR>cmdBTV.Act iveConnection = BTVConn<BR>cmdBTV.Commandtype = adCmdText<BR>ssql="select * from Class"<BR>cmdBTV.CommandText = ssql<BR><BR>Set rsBTV = server.CreateObject("ADODB.Recordset")<BR>rsBTV.Op en cmdBTV,,adOpenForwardOnly,adLockReadOnly<BR><BR><B R>while not rsBTV.eof<BR>Response.Write "&#060;p&#062;" & rsBTV(0) & "&#060;/p&#062;"<BR>rsBTV.MoveNext<BR>wend<BR><BR>BTVConn. Close<BR>%&#062;<BR><BR>&#060;/BODY&#062;<BR>&#060;/HTML&#062;<BR><BR><BR>Has anyone else had issues with connecting to btrieve through ODBC? Anyone know why using a server.createobject fails when a createobject doesn&#039t? I called the tech help at pervasive and this stumped 3 of them so far, Microsoft IIS and Interdev help are at a loss as well.. Old dev server works fine, a new fresh server fails.<BR><BR><BR><BR><BR>

  2. #2
    Join Date
    Dec 1969

    Default RE: ADODB Connection to btrieve database failing i

    Hm have you checked to make sure that the permissions are correct on the ado dlls? Try setting it to everyone with full control and see if it helps. Just a guess..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts