Hello guys, <BR><BR>i have been reading about consuming web services for the last 2 days and at the same time trying to get one to work. I am using the full install of visual studio .net enterprise architect. Here is what i am doing <BR><BR>1.) i am starting a new project. <BR>2.) adding a web reference to: http://www.nexus6studio.org/Services/StockQoute.asmx?wsdl <BR>3.) adding this code to my page load event to call the web service <BR> Dim o As New Stocks.GetQuotes() <BR> Response.Write(o.GetDetailQuote("msft")) <BR>4.) Compiling/building my project <BR><BR>as from what i have seen this is the correct way to consume web services, however every time i try i get a timeout error like this one <BR><BR>The operation has timed-out. <BR>Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. <BR><BR>Exception Details: System.Net.WebException: The operation has timed-out. <BR><BR>Source Error: <BR><BR><BR>Line 58: &#060;System.Web.Services.Protocols.SoapDocumentMe thodAttribute("http://nexus6studio.org/Services/GetDetailQuote", RequestNamespace:="http://nexus6studio.org/Services/", ResponseNamespace:="http://nexus6studio.org/Services/", Use:=System.Web.Services.Description.SoapBindingUs e.Literal, ParameterStyle:=System.Web.Services.Protocols.Soap ParameterStyle.Wrapped)&#062; _ <BR>Line 59: Public Function GetDetailQuote(ByVal Ticker As String) As DetailQuote <BR>Line 60: Dim results() As Object = Me.Invoke("GetDetailQuote", New Object() {Ticker}) <BR>Line 61: Return CType(results(0), DetailQuote) <BR>Line 62: End Function <BR><BR><BR>Source File: c:inetpubwwwrootdotnetcsStocksWeb ReferencesStocksReference.vb Line: 60 <BR><BR><BR><BR>i have also tried to use o.Timeout = -1 (which is infinite) but that makes the aspnet exe timeout and error after 180 seconds. When i set a break point on the line that is erroring i noticed that it&#039;s not setting the result() <BR><BR>I know this web service works as others have gotten it to work using the same method i am. If this was the only one i couldn&#039;t get to work i wouldn&#039;t care, however i downloaded the WSEQuickstarts and i tried to consume one of them locally on my machine. Same Error! <BR><BR>I am not running a proxy server or a firewall program. <BR>My thoughts are that something has to be mis-configured and that is why ALL web services i try to consume are Timing Out. <BR><BR>Any help on this subject is greatly appreciated. <BR><BR>Joe Crawford