Cannot connect to Oracle using IIS 3.0

Results 1 to 2 of 2

Thread: Cannot connect to Oracle using IIS 3.0

  1. #1
    Join Date
    Dec 1969

    Default Cannot connect to Oracle using IIS 3.0

    HI All!<BR>could anybody tell me why iam not able to connect to oracle db..iam running my asp pages on <BR><BR>the following....<BR>1. web server server: IIS 3.0<BR>2. Oracle ver: 7.3x(on a remote server)<BR>3. Microsoft ODBC Driver for oracle ver:2.573.4202.00<BR>4. SQL Net version:<BR><BR>Iam using the following connect string in my asp page<BR>********************************<BR>strSql ="select name from test"<BR>Set oConn = Server.CreateObject("ADODB.Connection")<BR>oConn.O pen "my_dsn", "my_uid", "my_pwd"<BR>Set oRS = Server.CreateObject("ADODB.Recordset")<BR> strSql, oConn<BR>*******************************<BR><BR>I get the follwing error when i try to run my asp page<BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039 80004005&#039 <BR>[Microsoft][ODBC Driver Manager] Driver&#039s SQLAllocHandle on SQL_HANDLE_ENV failed <BR><BR>I dont know if i have to use a different set of oracle drivers or ODBC drivers. When I <BR><BR>tested the above pages on my PWS which runs (IIS 4.0) This pages runs perfectly well..<BR><BR>Any help would be greatly appreciated..<BR><BR>TIA<BR><BR>Pavan

  2. #2
    Join Date
    Dec 1969

    Default RE: Cannot connect to Oracle using IIS 3.0

    Don&#039t exactly know what the problem is but try this, who knows..:-)<BR>write the sql statement after opening the connection object.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts