help me help me help me...

Results 1 to 3 of 3

Thread: help me help me help me...

  1. #1
    Join Date
    Dec 1969
    Posts
    5

    Default help me help me help me...

    well...i have tried a couple of things...here is my code..<BR>&#060;% <BR> Set Mailer = Server.CreateObject ("SMTPsvg.Mailer") <BR> Mailer.FromName = Request.Form("name")<BR> Mailer.FromAddress = Request.Form("from")<BR> Mailer.Subject = Request.Form("subject")<BR> Mailer.BodyText = Request.Form("contact")<BR> Mailer.RemoteHost = "smtp.themortgagehouse.com.hosting.pacbell.net"<BR > Mailer.Priority = 1<BR><BR> Mailer.AddRecipient "Dan Shank", "dshank@themortgagehouse.com" <BR> Mailer.AddCC "dan shank", "dan_shank@msn.com" <BR><BR> if Mailer.SendMail then <BR> &#039; Message sent sucessfully <BR> response.write ("Thank you, you will get an email confirmation within 24 hours.") <BR> else <BR> &#039; Message send failure <BR> response.write ("There was an error while submiting your information, please report all problems to Dan Shank (818)227-0922 or (818)292-6598. Thank You") <BR> response.write ("The error was: " & Mailer.Response) <BR> end if <BR><BR>Set Mailer = Nothing <BR>%&#062; <BR><BR>here is my errror...<BR>Server object error &#039;ASP 0177 : 800401f3&#039; <BR><BR>Server.CreateObject Failed <BR><BR>/flyers/asp/form.asp, line 2 <BR><BR>Invalid class string <BR><BR><BR>SMTPsvg is installed on the server and there are other web folders on the server that can send mail...but they use frontpage....i dont like frontpage.....what can i do...what is the next step to take...do i just submit and use frontpage...or do i continue to try to hand code my own scripts...any solutions???

  2. #2
    Join Date
    Dec 1969
    Posts
    96,118

    Default It's not installed...

    Oh, the DLL for SMPTsvg might be present on the server, but that "Invalid class string" message says the it&#039;s not registered.<BR><BR>And it *must* be in the registry to be accessible as an ActiveX object.<BR><BR>To prove me wrong (or right), bring up <BR> regedit<BR>(or regedt32 if this is an old NT server) and do a FIND for SMTPsvg.Mailer<BR><BR>If you find it, then check that its InProcServer32 (I think that&#039;s the right property...but close if not) points to the location where the DLL actually resides. If not, that would be a problem. (But I think that would get a different error than "invalid class string".)<BR><BR>If you don&#039;t find it...<BR><BR>Time to install it.<BR><BR>Go to the directory where the DLL is located and do<BR> regsvr xxx.dll<BR>(again, it might be regsvr32 on some machines).<BR><BR>This is 100% off the top of my head, so apologies if some of the names are a character or two off.<BR><BR>

  3. #3
    Join Date
    Dec 1969
    Posts
    5

    Default RE: It's not installed...

    thank you Mr. Wilkinson, you have been more than helpfull

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •