No data returned from a memo field

Results 1 to 6 of 6

Thread: No data returned from a memo field

  1. #1
    Join Date
    Dec 1969
    Posts
    226

    Default No data returned from a memo field

    When requesting data from a memo field out of an Access database with &#060;%=rsInfo("Text")%&#062; the returned value is an empty string.<BR>What&#039s the trick?

  2. #2
    Shawn Clabough Guest

    Default RE: No data returned from a memo field

    Could you give us more about how you&#039re querying the database and creating the recordset? It&#039s possible that &#060;%=rs.Fields("Text")%&#062; would do the trick.

  3. #3
    Join Date
    Dec 1969
    Posts
    226

    Default RE: No data returned from a memo field

    The query:<BR>Set objConn=Server.CreateObject("ADODB.Connection")<BR >objConn.Open DSN<BR>Set rs = objConn.Execute("SELECT * FROM Table WHERE Selector=&#039SELECT&#039";)<BR>&#060;%=rs("Text") %&#062;<BR>That&#039s it...<BR>

  4. #4
    Nathan Pond Guest

    Default RE: No data returned from a memo field

    It is probably a bug in ODBC or some such, I had the exact same problem when my site was running on access. All I could do to work around it is assign the value to a variable directly after the SQL call. And then reference the variable from there on out.<BR><BR>btw, it isn&#039t only an access problem, When I upgraded my site to SQL Server 7.0 I thought the problem would be solved, but in reality it isn&#039t, and in some cases even worse. What I&#039ve turned to is only making MEMO fields when absolutely neccesary, and using Varibales within the ASP.<BR><BR>You might want to look at your table design, is it imperative that the column be of memo type? If not your better off just giving it the 255 char limit.<BR><BR>Hope I helped<BR><BR>Nathan


  5. #5
    Join Date
    Dec 1969
    Posts
    226

    Default RE: No data returned from a memo field

    Nathan:<BR><BR>Thanks a lot. I cannont believe that this is it.<BR>Now it&#039s working...<BR><BR>Thanks again ;-)

  6. #6
    Linda N. Guest

    Default RE: No data returned from a memo field

    If you are possibly talking about populating a memo field on a form with information here is what I did:<BR><BR>&#060;P&#062;Description: <BR>&#060;TEXTAREA cols=60 rows=6 name=description&#062;&#060;%=rst("prob_descriptio n")%&#062;&#060;/TEXTAREA&#062;<BR><BR><BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •