Session state lost by migration to server

Results 1 to 2 of 2

Thread: Session state lost by migration to server

  1. #1
    Join Date
    Dec 1969

    Default Session state lost by migration to server

    Hello<BR><BR>I have migrated my web site from a Windows 2000 server iis 5 to a remote host which operates on Windows .NET Server 2003.<BR><BR>The new configuration does not seem to maintain session IDs for more than 15 seconds.<BR><BR>If you visit<BR>I have placed an indicator at the bottom of each page. The first # is the session.timeout and the second is session.sessionid<BR><BR>if you login with "test1" using pass "login12" and visit a few pages, go to the shop, browse around, and go back to the "course" button you will see that after a while the session id changes and it asks the user to log back in.<BR><BR>It worked fine before. What is this due to? <BR><BR>Thanks<BR>Alex<BR>

  2. #2
    Join Date
    Dec 1969

    Default web.config

    it might be something with your new server. if so, i dont know what the answer is and that is something to ask an mcse.<BR><BR>however, it might also be in your code. and if so, the first place to look is in your web.config file. as you may know, the default length of time to keep each session open is set in that file. here is how it might look if it is set "properly."<BR>-----------------------------------------------------------------<BR>&#060;configuration&#062;<BR> &#060;system.web&#062;<BR> &#060;sessionState mode="InProc" cookieless="false" timeout="20" /&#062;<BR> &#060;/system.web&#062;<BR>&#060;/configuration&#062;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts