Problems with ADODB.Connection

Results 1 to 4 of 4

Thread: Problems with ADODB.Connection

  1. #1
    Zvonko Guest

    Default Problems with ADODB.Connection

    Hello!<BR><BR>I&#039m just beginner in ASP and I have one quite big problem.<BR>I use x=server.createobject("adodb.connection")<BR>but then it returns an error, that it couldn&#039t find data source and that default driver hasn&#039t been defined. I used: {Microsoft Access Driver (*.mdb)} and database was where it should be.<BR><BR>Can you help me?<BR><BR>Regards<BR>Zvonko

  2. #2
    Piette Guest

    Default RE: Problems with ADODB.Connection

    Are you using the x.Open method? What is your next line?

  3. #3
    Tixo Guest

    Default RE: Sample

    &nbsp;<BR>x.ConnectionString = "Driver={Microsoft Access Driver (*.mdb)};Dbq=" & strDatabase & _<BR> ";UID=" & strUser & ";PWD=" & strPassword & ";DefaultDir=" & strPath<BR>x.Open

  4. #4
    Zvonko Guest

    Default RE: Problems with ADODB.Connection (the code I use

    Here&#039s the code I use:<BR><BR>set conn=server.createobject("adodb.connection")<BR>co nnpathh="DBQ=" & server.mappath("/data/Database.mdb")<BR>conntemp.Open "DRIVER={Microsoft Access Driver (*.mdb)}; " & cnpath<BR><BR>I think this code should work. <BR>I have Win98, latest MS Data access components and MS PWS (local). My real web server is WIN NT4, IIS4 and latest MS Data Components.<BR><BR>Regards<BR>Zvonko<BR><BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts