IIS/ASP page caching, revisited

Results 1 to 2 of 2

Thread: IIS/ASP page caching, revisited

  1. #1
    Join Date
    Dec 1969

    Default IIS/ASP page caching, revisited

    This isn&#039;t a question, just a fix I found.<BR><BR>In the past there have been several threads discussing a problem where IIS was caching ASP pages. Lots of reasons were talked about and suggestions made, but none of them seemed to result in a solution (believe me I tried every one of them).<BR><BR>Recently, I&#039;ve run into the same problem. I&#039;d run an ASP page, edit the source code directly, and run it again only to find the previous version of the page still being executed. It has been a long time since I&#039;ve messed around with my IIS settings, so I know they have not changed. My point here is not to argue against any of the suggestions put forth, but all the same, they did not work for me.<BR><BR>Anyway, here&#039;s what I found: The caching problem on my server was only occuring on one of my virtual directories (albeit one who&#039;s files are frequently used and modified). Every other virtual directory in my wwwroot directory didn&#039;t have the problem.<BR><BR>I think you can see where I&#039;m going here:<BR>- First, I copied the entire contents of the virtual directory to a safe location.<BR>- Then I deleted the virtual directory from the IIS control panel.<BR>- Then I deleted the actual directory through Windows Explorer.<BR>- Just to be safe, I restarted IIS.<BR>- I then created a new directory with the same name, created a new virtual directory and mapped it to the new physical directory.<BR><BR>(NOTE: No solution involving renaming the directory will work. You need to delete it and create it from scratch, so be sure to back up your files to a safe place first!)<BR><BR>After that, I fired up the site, ran some pages, edited them, ran them again, and bingo, the changes took. No more caching. I never figured out why it started happening, but at least I have a way around it now, which is better tnan nothing. The fact that just recreating the physical/virtual directory (without changing any IIS settings or ASP code) solved the problem tells me that something beyond my control went wrong, probably with IIS itself.<BR><BR>I hope this helps anyone else who was/is having the same problem. Of course (as always), your milage may vary.<BR><BR>Cheers.<BR><BR>P.S. - My specific server setup is Windows 2000 SP2 with IIS 5.0.

  2. #2
    Join Date
    Dec 1969

    Default Thank you...

    for posting this.<BR>I&#039;m sure it will help a large number of people.<BR>I just hope that there is a better/cleaner solution.<BR>I guess we&#039;ll see how much of this has been solved in IIS 6.<BR>Cheers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts