AS400 connection with ASP

Results 1 to 3 of 3

Thread: AS400 connection with ASP

  1. #1
    Join Date
    Dec 1969

    Default AS400 connection with ASP

    Ok folks I need some real help. I have to connect to a AS400 db. I have Client access installed on my iis server.<BR>the following code does not work it just locks up when the is used if i comment it out then the state comes back as 0, but with in place it just runs and runs. Help please<BR>&#060;% <BR>dim DNS1, objConn, SQLString, rs, strSERIAL<BR><BR>%&#062;&#060;% <BR>Set objConn = Server.createobject("ADODB.connection")<BR><BR>obj Conn.connectionstring = "UID=USERQC;PWD=Lewinsky;SYSTEM=;DRIVER= {Client Access ODBC Driver (32-bit)};DBQ=KPDAT11;"<BR><BR>response.wr ite objconn.state<BR>Set rs=server.createobject("ADODB.Recordset") <BR><BR>&#039;rs.Open "SELECT * FROM KPDAT11.I2IC150M WHERE I2LCPPN = &#039;H711A&#039;", objConn<BR> %&#062;

  2. #2
    Join Date
    Dec 1969

    Default Crosspost from DB forum <eop>

    Please see FAQ #110

  3. #3
    Join Date
    Dec 1969

    Default Forget trying to connect via ASP for a sec

    Go directly into the &#039;Data Sources(ODBC)&#039; section from your control panel on that server and test the ODBC connection from there. Was that successful?<BR><BR>Also, what is the exact ODBC driver you are using? Is it a native driver (i.e. - IBM) or is it from a third party like Merant? <BR><BR>I&#039;m assuming when you say AS400 db that you mean a DB2 database. <BR><BR>Is the AS400 configured properly to "listen" for db calls via TCP/IP?<BR><BR>Good luck<BR>Pete

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts