v.basic - can't get any scripts to run

Results 1 to 4 of 4

Thread: v.basic - can't get any scripts to run

  1. #1
    Join Date
    Dec 1969

    Default v.basic - can't get any scripts to run

    Hi, I am having a lot of trouble getting any ASP scripts to run on my pc using PWS. If I save this text with a .asp extension, it simply prints everything between the &#060;% and /%&#062; tags to the screen instead of running the script. The file is stored in c:/Inetpub/wwwroot/ and I have enabled scripts,read and execute for that directory<BR><BR>Any help with this problem would be very appreciated<BR><BR>Cheers <BR><BR>Dominic<BR><BR>&#060;html&#062;<BR>&#060;h ead&#062;<BR>&#060;title&#062;My First ASP script&#060;/title&#062;<BR> &#060;body&#062;<BR>&#060;%<BR>Dim Today &#039 declares Today as a variable<BR>Today = Date() &#039 makes Today&#039s value today&#039s date<BR>Response.Write "Hello, ASP World!" <BR>Response.write "<BR>My first script was created "<BR>response.Write(Today) <BR>response.end<BR>%&#062;<BR> <BR>&#060;/center&#062;<BR>&#060;/body&#062;<BR>&#060;/html&#062;

  2. #2
    ali Guest

    Default RE: v.basic - can't get any scripts to run

    I am having exactly the same problem and I have tried everything you did. I am new at active server pages and I am wondering if you figured it out or if you have heard from anyone about this issue. Your help is very much appreciated<BR>Thanks

  3. #3
    peterjl@atlantech.com.au Guest

    Default RE: v.basic - can't get any scripts to run

    You need to add the following line to the top of you page:<BR>&#060;%@language=VbScript%&#062;<BR><BR>A lso you cannot run an ASP by typing its file path (c:inetpubwhatever), you must run it through the server via a URL like:<BR>http://localhost/yourfile.asp<BR><BR>ASP is only processed by the server. If you double-click the PWS icon in your system tray, you will see what the URL is on the first page of the PWS Manager. "localhost" is the default name for the base web server on you machine, but if you want to call-up the page from another machine on your lan you will need the machine name. So if you are testing ASP from the same machine that is running the server, you can use either:<BR><BR>http://localhost/yuorfile.asp<BR>or <BR>http://yourmachinename/yourfile.asp<BR>where yourmachinename = the name you gave your pc in network properties.<BR><BR>If you are accessing it from another machine you must use:<BR><BR>http://yourmachinename/yourfile.asp<BR>

  4. #4
    ali Guest

    Default RE: v.basic - can't get any scripts to run

    Thanks Peter for your tips. I was able to see my asp pages after I reinstalled the PWS. My problem now is when I use Frontpage to create a new web under http://servername/myweb on my local machine, I get an error message saying to check the server extensions. The server extensions are there But I have no problem creating a web under c:/myweb It seems like frontpage defaults to c: instead of http://server as I have at work? how do I make my frontpage create a web under http:servername? on my local machine?<BR>anyone&#039s help is very much appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts