Won't Work with Vectors!

Results 1 to 2 of 2

Thread: Won't Work with Vectors!

  1. #1
    Join Date
    Dec 1969
    Posts
    701

    Default Won't Work with Vectors!

    I can&#039;t figure this out I have a function that changes the time from the current time and increases it by 6 hours to place along the x axis of a graph, which is as follows:<BR><BR>FUNCTION getHour(time1, offset)<BR>time1=split(time1, ":")<BR>time2=cInt(time1(0))+cInt(offset)<BR>I F time2 &#062; 24 THEN<BR>getHour=cInt(time2-24)<BR>ELSE<BR>getHour=time2<BR>END IF<BR>END FUNCTION<BR><BR>When it&#039;s called in a normal asp page it works fine, but when I put it into my SVG it mis-calculates, has anybody come across this before, it makes no sense to me, here is the code for the SVG:<BR><BR>&#060;g<BR>style="font-size:9; <BR> font-weight:very-thin; <BR> stroke:white; <BR> stroke-width:0.01; <BR> text-anchor:middle;<BR> fill:white;"&#062;<BR><BR> &#060;text x="25" y="237"&#062;&#060;%=getHour(time(),"0")%&#062;:00 &#060;/text&#062;<BR> &#060;text x="81.25" y="237"&#062;&#060;%=getHour(time(),"6")%&#062;:00 &#060;/text&#062;<BR> &#060;text x="137.5" y="237"&#062;&#060;%=getHour(time(),"12")%&#062;:0 0&#060;/text&#062;<BR> &#060;text x="193.75" y="237"&#062;&#060;%=getHour(time(),"18")%&#062;:0 0&#060;/text&#062;<BR>&#060;/g&#062;

  2. #2
    Join Date
    Dec 1969
    Posts
    701

    Default Don't Worry I Got It

    It seems it messed up because I included the file, I don&#039;t have a clue why, but sometimes it works with the include and sometimes it doesn&#039;t...go figure!?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •