Create Application Object Not working on IIS 5.0

Results 1 to 2 of 2

Thread: Create Application Object Not working on IIS 5.0

  1. #1
    Join Date
    Dec 1969

    Default Create Application Object Not working on IIS 5.0

    This is the error message that I am receiving.<BR><BR>Call was rejected by callee. <BR>/test/buildword.asp, line 2<BR><BR>The Server has word installed on it.<BR>IIS 5.0 Directory Permissions are set to Scripts and Executables.<BR>The Folder Directory is allowing everyone write permissions to the directory.<BR><BR>This is my Code<BR>&#060;%<BR>Set WordApp = CreateObject("word.application")<BR>Set WordDoc = WordApp.Documents.Add()<BR><BR>WordApp.Application .Visible = False<BR><BR>Set MyRange1 = WordDoc.Paragraphs.Add.Range<BR>MyRange1.InsertBef ore("Test Document")<BR>MyRange1.Style = "Heading 1"<BR><BR>Set MyRange1 = WordDoc.Paragraphs.Add.Range<BR>MyRange1.InsertBef ore("This is a test document, generated on the server at " & Now())<BR>MyRange1.Font.Bold = True<BR><BR>Set MyRange1 = WordDoc.Paragraphs.Add.Range<BR>MyRange1.InsertBef ore(vbCRLF & "Hope you like it.")<BR><BR>WordDocPath = Server.MapPath(" estpages")<BR>WordDoc.SaveAs WOrdDocPath & "Test1.doc"<BR>WordDoc.Close<BR>WordDoc.Quit<BR><B R>Set WordDoc = Nothing<BR>Set WordApp = Nothing<BR><BR>Response.Write "&#060;p&#062;&#060;b&#062;&#060;a href=&#039;" & worddocpath & "\" & "test1.doc"&#039;&#062;Get Document&#060;/a&#062;"<BR>%&#062;<BR><BR>TIA Jason Buck<BR>

  2. #2
    Join Date
    Dec 1969

    Default Try Server.CreateObject...

    ...on your first line, instead of simply CreateObject.<BR><BR>I&#039;ve never done this, but since dozens or hundreds of others have...<BR><BR>And should you set Visible=False *before* you add to the documents?<BR><BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts