I am having a strange problem<BR>I am inserting a record from my page using stored procedure.<BR>I have a stored procedure called "AddCurrency"<BR>I am using the following code which I have compiled as DLL<BR><BR>Public Function AddCurrency(ByVal currbig_name As String, ByVal currsmall_name As String, ByVal curr_conv As String) As Integer<BR><BR>Dim myConnection As New SqlConnection(ConfigurationSettings.AppSettings("M M_CONNECTION_STRING_mediacon"))<BR>Dim myCommand As New SqlCommand("AddCurrency", myConnection)<BR>...<BR><BR>Then I have my form which has the following code<BR><BR><BR>Sub AddCurrencyBtn_Click(ByVal sender As Object, ByVal E As EventArgs)<BR>If Page.IsValid = True Then<BR>Dim accountSystem As New mediawork.AddDB()<BR>If accountSystem.AddCurrency(currbig_name.Text, currsmall_name.Text, curr_conv.Text) Then<BR>&#039;Send message that currency added<BR>Message.Text = "New currency &#060;" & "u" & "&#062;" & currbig_name.Text & "&#060;" & "/u" & "&#062; Added Successfully!"<BR>Else<BR>Message.Text = "New currency Addition Failed! &#060;" & "u" & "&#062;" & currbig_name.Text & "&#060;" & "/u" & "&#062; already exists."<BR><BR>End If<BR>End If<BR>End Sub<BR>..<BR><BR>Now my problem is, it was working fine all these days, suddenly until yesterday, It started giving strange problems like the data is not inserting "SOMETIMES", I tried to figure out where the link is broken, but could not figure it out.<BR><BR>I tried renaming function in the DLL (without reflecting the change in my form top check whether the dll is functioning)<BR><BR>Public Function AddtestCurrency(ByVal...)<BR><BR>I did get an error which says ...<BR>AddCurrency is not a member of Add...<BR>So the link is okay, Then I tried changing the SQL Procedure name in the DLL from AddCurrency to Add12121Currency (But not to the SQL Server)... And when I submitted the form It did not give me any error. It should have normally told me Stored Procedure not found, or etc. etc. IF the stored procedure name is mentioned fine, It inserts the data, If if its wrong, it does not give me any error. Where could be the problem, SQL or ASP.NET<BR><BR>This form was working fine all these days...<BR>And this is happening to all my forms and request<BR><BR>Please help<BR>Thanx