Hi all, this one is truly stumping me. Imagine the following:<BR><BR>In the beginning, I had a single project, ADDRESS, which contained a Reference to an unmanaged COM component...let&#039;s call it NLIB. NLIB ran fine, and the application worked.<BR><BR>I created a new project, PHONE, and decided that since I needed a lot of the same functionality from Address (yes, ADDRESS and PHONE do need to be separate Projects/Applications), I&#039;d cut that functionality out of ADDRESS and place it into a third project, NWRAPPER.<BR><BR>I removed my NLIB reference from ADDRESS, since NWRAPPER now contained that reference, and added a reference to NWRAPPER in my ADDRESS project. It compiled fine, but when I tried to run ADDRESS, I got the error (sorry, I don&#039;t have the exact syntax because I haven&#039;t been able to reproduce it today, oddly enough), "...NLIB is being used by another resource." I rebuilt the entire Solution, tried again, rebuilt, tried...sometimes it would run, sometimes it wouldn&#039;t.<BR><BR>That&#039;s only part of the problem.<BR><BR>When it DOES run, it instantiates NLIB just fine. I&#039;m even able to set its properties. But when I call NLIB.RunScript(), which is the magic moment, my application hangs, as if in an infinite loop.<BR><BR>Any ideas? Thanks in advance,<BR>Eric