I really REALLY hope someone here can help me, as boss man isn&#039;t very pleased with the fact that I spent all day working on this problem and haven&#039;t gotten very far.<BR> <BR>I&#039;m trying to remotely debug an asp.net application that resides on our local server here at the office. I can debug locally just fine, but attempting to debug on the server yields this error: (Note, I&#039;m automatically attaching to the process and I have been unable to successfully manually attach)<BR> <BR>Error while trying to run project: Unable to start debugging on the web server. You do not have permissions to debug the server. Verify that you are a member of the &#039;Debugger Users&#039; group on the server. Would you like to disable future attempts to debug ASP.NET pages for this project? <BR> <BR>Clicking on the "Help" button of the above mentioned error dialog box yields lots of would-be useful information for which I have read FAR too many times today. <BR> <BR>1. The server OS is Windows 2k Server<BR>2. I&#039;ve tried every combination of username/password acceptable in<BR>the ProcessModel section of the machine.config<BR>3. The application runs perfectly fine when I&#039;m not trying to debug<BR>4. The URL for the application is<BR>http://ProjectName.internal.mycompany.com<BR>&#060;http://projectname.internal.mycompany.com/&#062; . I think this might have something to do with it as I&#039;ll explain later.<BR>5. I have configured a new website in IIS to support this project.<BR>The home directory is not located at c:inetpubwwwRootProjectName but instead is located on another local hard drive on the server. This might be another problem.....?<BR>6. I AM a member of the Debugger Users group on the server. As a<BR>matter of fact, just to see if I could get it to work, I made sure that Everyone was also part of the Debugger Users group..... as well as Domain Admins, Administrators, etc and visa versa.. Needless to say my local domain has seen more secure days in the past but I had to do everything I could to try to get this to work. <BR>7. The server has a full installation of VS.net on it INCLUDING the<BR>Remote Components. (Is there a way to verify this just to make sure?)<BR>8. VS.NET was installed LONG after IIS was installed, but just to<BR>make sure I ran the suggested dotnetfx.exe program.<BR>9. The Start Page is properly specified, otherwise it wouldn&#039;t run<BR>in release mode, would it?<BR>10. The IIS security settings are correct by default and haven&#039;t<BR>been changed.<BR> <BR>So you can see I&#039;ve followed all the required directions and unless VS doesn&#039;t complain when you do something wrong, I believe I did them all right. And you would think that after 8 hours of trying that SOMETHING would work. I also tried creating another project and hosting it on the server exactly like the one I&#039;m working on now and I get the same results. <BR> <BR>The only REVEALING thing I can share with you is that when I log off of my computer and log back in using another Domain Admin account (actually, I used the server&#039;s Administrator account) I get the following error when I try to load the project.<BR> <BR>The projects &#039; ProjectName.internal.mycompany.com &#039; is on an untrusted web server. Opening this project may cause code to be executed with full trust. <BR>Do you want to continue opening this project? If you do not trust the source of this project, you should choose &#039;No&#039;.<BR> <BR>So what is an "untrusted web server?" The web server is on the same computer as our *%^#@$^@#$ domain controller! Could it be my project name that is causing the problem? Could it be the fact that I specified an alternate location other than c:inetpubwwwRoot? <BR> <BR>Oh dearest .net... How can I love thee and DESPISE thee so much at the same time? <BR>