global.asa never works!

Results 1 to 7 of 7

Thread: global.asa never works!

  1. #1
    omalleyb Guest

    Default global.asa never works!

    Hi,<BR> <BR> can anyone please enlighten me as to why global.asa never seems to work for me. It seems relatively simple - I&#039m absolutely certain that my code and tags in the file are correct - it just never gets called or something. You just place it at the root of your web app right? Aarrggghh! Thanks.<BR><BR>

  2. #2
    Sathiya Guest

    Default RE: global.asa never works!

    Their can be so many reasons. i can give you some reasons, global.asa will not be called if you dont call a asp page , if you call a HTML page also it will not be invoked. how u know that global.asa is not working did u did some response write. If u can explain it will be helpful.

  3. #3
    omalleyb Guest

    Default RE: global.asa never works!

    Thanks,<BR><BR> I&#039m calling an ASP so the global file really should be invoked. In the global.asa I&#039m using:<BR><BR>Sub Session_OnStart<BR> Session("varTest") = "Hello World!"<BR>End Sub<BR><BR>and then simply getting my test ASP to:<BR><BR>&#060;%=Session("varTest")%&#062;<BR><B R>Which returns nothing. Everything else around it works fine. Am I missing something simple here?<BR><BR>

  4. #4
    Sathiya Guest

    Default RE: global.asa never works!

    are you using frames.

  5. #5
    Trung Dang Guest

    Default RE: global.asa never works!

    Did you remember to "create" the application on your new server?<BR>Use MMC, open up your default web server, select the directory that represents your project/application. Right click to bring up the short cut menu then select properties. In the Directory tab, in the Application Settings section, you should see a "Create" button (if you had created the application, you should see "Remove" instead.) You&#039ll also need to apply the "execute" permission on this directory.<BR>

  6. #6
    omalleyb Guest

    Default RE: global.asa never works!

    Sorry for delay - I&#039m in Ireland on GMT...<BR><BR>But no, I&#039m not using frames. Here&#039s the contents of the two files simplified to bare bones - could you see if they work for you?<BR><BR><BR>Global.asa:<BR><BR>&#060;SCRIPT LANGUAGE=VBScript RUNAT=Server&#062;<BR><BR>Sub Session_OnStart<BR> Session("myConnStr") = "targdev"<BR>End Sub<BR><BR>&#060;/SCRIPT&#062;<BR><BR><BR>TestSession.asp:<BR><BR>&# 060;%@ LANGUAGE="VBSCRIPT" %&#062;<BR>&#060;html&#062;<BR>&#060;head&#062;<BR >&#060;title&#062;Test Page&#060;/title&#062;<BR>&#060;/head&#062;<BR>&#060;body&#062;<BR>Connection String: &#060;%=Session("myConnStr")%&#062;<BR>&#060;/body&#062;<BR>&#060;/html&#062;<BR><BR>If these are placed in the same folder and I call testSession.asp shouldn&#039t global.asa get called first and therefore my test Session variable be instantiated? I must be missing something. <BR><BR>

  7. #7
    omalleyb Guest

    Default global.asa now works!

    Thanks a million!<BR><BR> That was exactly what I needed, nice to finally get it working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts