Need to post values via email!!!!

Results 1 to 6 of 6

Thread: Need to post values via email!!!!

  1. #1
    Samuel Guest

    Default Need to post values via email!!!!

    I cant seem to find a way to create an asp that sends the response values to an email address.<BR>I need to accept values and have those values sent to me via an email that is generated and sent automaticaly.<BR><BR>-PLEASE!!!!!!!!!<BR>

  2. #2
    geeoff Guest

    Default RE: Need to post values via email!!!!

    From your message, it sounds like you could use the CDONTS package that comes as part of the NT Option Pack. Check if you have the SMTP service installed. Using the CDONTS is pretty straight-forward and it works fine.<BR><BR>HTH,<BR><BR>geeoff

  3. #3
    Samuel Guest

    Default RE: Need to post values via email!!!!

    Thanks...but im getting a freaky error I cant figure out.<BR>I assume everything is working fine, or the system wouldnt create the object.<BR>Here is my code (**** near striped out of the help file)<BR><BR>Set myMail = CreateObject("CDONTS.NewMail") <BR> myMail.From = "" <BR> myMail.To = "" <BR> myMail.Subject = "Test stuff" <BR> myMail.Body = "This is a sample message." <BR> myMail.Send <BR>Set myMail = Nothing <BR><BR>Here is the error I get:<BR><BR>error &#039 80070003&#039 <BR>The system cannot find the path specified. <BR><BR>/DesignerNails/forms/postAlternativeEntry.asp, line 49 <BR><BR>Line 49 is the one that contains the mymail.send method.<BR>I have also tried it with sending the parameters with the method, but I get the same error.<BR><BR>I figured there would be an error creating the object, or even assigning the objects properties if it didnt exist in the first place.<BR><BR>Any more insight would be deeply apreciated.<BR>

  4. #4
    Ryan S. Guest

    Default RE: Need to post values via email!!!!

    That example assumes you have declared the object as a runat=Server type.<BR><BR>You can declare the object or have the line say this:<BR>Set myMail = Server.CreateObject("CDONTS.NewMail") <BR><BR>

  5. #5
    geeoff Guest

    Default RE: Need to post values via email!!!!

    I got this from the MSDN resource.......maybe it will help you. It is kinda long.<BR><BR><BR>PRB: Path Not Found When Using CDONTS with IMC<BR>ID: Q235681 <BR><BR>--------------------------------------------------------------------------------<BR>The information in this article applies to:<BR><BR>Microsoft Exchange Server, version 5.5 <BR>Collaboration Data Objects (CDO) for NTS, versions 1.2, 2.0<BR><BR>--------------------------------------------------------------------------------<BR><BR><BR>SYMPTOMS<BR>If you have a configuration where, Microsoft Exchange server and Internet Information server (IIS) are installed on the same computer and the Internet Mail Services (IMS) from Microsoft Exchange server is being used to deliver SMTP messages, you might get the following error message when trying to send e-mail using the CDONTS.NewMail object: <BR><BR>&#039 80070003&#039 - The system cannot find the path specified <BR><BR><BR><BR>CAUSE<BR>When the Windows NT 4.0 Option Pack was installed on your server, it installs CDONTS. CDONTS, by default, is configured to use the InetpubMailroot folders to send and receive e-mail. However, these folders do not exist unless the IIS SMTP service is also installed.<BR><BR>In the configuration mentioned in the SUMMARY section, IIS SMTP service is missing. <BR><BR><BR><BR>RESOLUTION<BR>To resolve the missing IIS SMTP service, you need to set the pickup directory for CDONTS to the IMCDATA directory used by your IMS. Therefore, the messages created by CDONTS will be delivered by the Exchange IMS. One method to do this is to first install the IIS SMTP service, and then disable it.<BR><BR><BR><BR><BR><BR>Start the Windows NT 4.0 Option Pack setup.<BR><BR><BR>Select the option to install the IIS SMTP service.<BR><BR><BR>You will receive a message informing you that you can either have this or your IMC. You need to click OK and continue as you will not be using this IIS SMTP service. (NOTE: You are using this setup just to configure the pick up directory.)<BR><BR><BR>After you continue with the setup, you will receive a dialog box prompting you to enter the pickup path. By default, the pickup path is set to InetpubMailroot. <BR><BR><BR>Change this to point to your IMCDATA folder.<BR><BR><BR>Continue with the Windows NT 4.0 Option Pack setup.<BR><BR><BR>You will need to stop the IIS SMTP service because you will not be using it since the Exchange IMS will be handling the message delivery for the messages created by CDONTS.<BR><BR><BR><BR><BR><BR>STATUS<BR>This behavior is by design. <BR><BR>Additional query words: <BR><BR><BR>Keywords : kbXchge kbXchge550 kbMsg kbCDONTS kbGrpMsg kbDSupport <BR>Version : WINDOWS:1.2,2.0; winnt:5.5<BR>Platform : WINDOWS winnt <BR>Issue type : kbprb <BR><BR>Last Reviewed: July 21, 1999<BR><BR><BR>--------------------------------------------------------------------------------<BR>

  6. #6
    Samuel Guest

    Default Thanks.... It worked

    I found the same article after awhile... Followed it and it worked. Now I have a new prob... It wont work on the server that is hosting the site! Some type of permission error, and the tek geeks there have no clue how to resolve it.Whcih makes me a little tiffed.<BR>Thanks for your help<BR><BR>Sameeeee

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts