WAP-pages in WML with ASP!

Results 1 to 2 of 2

Thread: WAP-pages in WML with ASP!

  1. #1
    Join Date
    Dec 1969

    Default WAP-pages in WML with ASP!

    Hi,<BR><BR>I&#039;m trying to create simple wml pages for wap terminals, just a database connection to get a text to present - but it doesn&#039;t work!<BR><BR>I have tried with standard wml pages (no asp code and with .wml as file extension) and it works fine. This makes me believe that I&#039;ve configured the correct mime types (text/vnd.wap.WML extension = .WML, image/vnd.wap.wbmp extension = .wbmp, text/vnd.wap.WMLscript extension = .WMLs). <BR><BR>When I rename a working wml code to .asp and just add one line, &#060;%Response.contenttype = "text/vnd.wap.wml%&#062; as line one - the response from a wap emulator is "Unsupported Content-Type: text/html"! The response with IE web browser is "Microsoft VBScript compilation error &#039;800a0409&#039;, Unterminated string constant, /filename 1, Response.contenttype = "text/vnd.wap.wml".<BR><BR>Heeeelp! My hair is getting greyer every day!<BR>/Donald

  2. #2
    Join Date
    Dec 1969

    Default I think that...

    ...there is a problem with the ASP code somewhere - hence the reason IS is bombing out.<BR><BR>The error code is also what is being sent to the WAP emulator to stop it being correctly shown.<BR><BR>However, have you set up the ASP.DLL file to parse .WML files? If so, then you don&#039;t have to rename all your WML files to ASP - it&#039;ll work anyway. Just copy the settings for ASP files from your IIS configuration into a WML setting.<BR><BR>Craig.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts