Provider error ' 80004005' - no clue

Results 1 to 2 of 2

Thread: Provider error ' 80004005' - no clue

  1. #1
    David Freer Guest

    Default Provider error ' 80004005' - no clue

    The following code (and this is the extent of it) is called from via post from another page. This code works the first time I access the page, but fails if I return to the previous page and re-post. From that point forward the code fails. The failure message is<BR><BR>Driver={Microsoft Access Driver (*.mdb)}; DBQ=d:inetpubwwwrootardentechappsUpgrades.mdb<BR>< BR>Provider error &#039 80004005&#039 <BR><BR>Unspecified error <BR><BR>/test.asp, line 21 <BR><BR><BR>&#060;%<BR>Dim strID, strTmp<BR>strID=Request.Form("RegID")<BR>set conn = server.createobject("ADODB.Connection")<BR>dbStrCo nnect = "Driver={Microsoft Access Driver (*.mdb)}; DBQ=d:inetpubwwwrootardentechappsUpgrades.mdb"<BR> Response.Write dbStrConnect<BR>Response.Write "<BR>"<BR>conn.open dbStrConnect &#039 THIS IS THE FAILING LINE<BR>SQL="SELECT * FROM Upgrade WHERE RegID=&#039" & strID & "&#039"<BR>Response.Write SQL<BR>Response.Write "<BR>"<BR>set rstUpgrades = conn.execute(SQL)<BR>if rstUpgrades.bof then<BR> Response.Write "Registration number not found."<BR>else <BR> Response.Write "Registration number found."<BR>end if<BR>rstUpgrades.close<BR>conn.close<BR>set rstUpgrades = nothing<BR>set conn = nothing<BR>&#037;&#062;<BR><BR>Driver={Microsoft Access Driver (*.mdb)}; DBQ=d:inetpubwwwrootardentechappsUpgrades.mdb<BR>< BR>Provider error &#039 80004005&#039 <BR><BR>Unspecified error <BR><BR>/test.asp, line 21 <BR>

  2. #2
    David Freer Guest

    Default RE: Provider error ' 80004005' - Actually some clue

    I should add that the code works fine on my local machine (PSW 4, IIS 4, NT 4 SP 5). If behaves strange when execute on the host site.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •