I am having problems calling a SQL-Server 2000 stored Procedure which I know works. I am using ADO and am passing the stored procedure one parameter. The error occurs when I invoke the store procedure and the error is as follows:<BR>"ODBC SQL-Server Error: Optional Feature Not Implemented."<BR><BR>The error occurs after I execute my stored procedure with the adoCmd.Execute statement. What am I doing wrong?<BR><BR><BR>Dim StartDate As Date<BR>Dim EndDate As Date<BR>Dim FundCode As String<BR><BR>Dim adoRS As adoDb.Recordset<BR>Dim adoConn As adoDb.Connection<BR>Set adoConn = CreateObject("ADODB.Connection")<BR>adoConn.Open "EquityWorks", "sa", "test"<BR><BR>Dim adoParam1 As adoDb.Parameter<BR>Dim adoParam2 As adoDb.Parameter<BR>Dim adoParam3 As adoDb.Parameter<BR>Dim adoParam4 As adoDb.Parameter<BR>Dim adoParam5 As adoDb.Parameter<BR>Dim adoParam6 As adoDb.Parameter<BR>Dim adoParam7 As adoDb.Parameter<BR><BR><BR>StartDate = CDate(Me.txtStartDate)<BR>EndDate = CDate(Me.txtEndDate)<BR>FundCode = Me.cmbSelectFund.Text<BR>&#039;Above Values Are Loaded <BR><BR>Dim adoCmd As adoDb.Command<BR>Dim Param1 As adoDb.Parameter<BR><BR>Set adoCmd = CreateObject("AdoDB.Command")<BR>&#039;Connection is working because I can get Recordsets back&#039;<BR><BR>adoCmd.ActiveConnection = adoConn<BR>adoCmd.CommandType = adCmdStoredProc<BR>adoCmd.CommandText = "vRV_ReserveReqByFund"<BR>&#039;Search Code: vips65 <BR>Set Param1 = adoCmd.CreateParameter("DateAsOf", 7, adParamInput)<BR>Param1.Value = "12/26/2002"<BR>adoCmd.Parameters.Append Param1<BR>adoCmd.Execute<BR>&#039;ERROR ERROR <BR>&#039;Error Comes 2 lines up with Execute Statement