PWS on a stand alone machine

Results 1 to 9 of 9

Thread: PWS on a stand alone machine

  1. #1
    Mucker Guest

    Default PWS on a stand alone machine

    Can I get PWS to work on a stand alone PC without connecting to my ISP. I only need it to develop and test a small database application locally on my home PC. Some of it&#039s features will not work unless I am connected to my ISP. I believe their is a way around this, by maybe editing the system registry. I would be grateful if anyone could help with my problem. Thank U.

  2. #2
    Join Date
    Dec 1969

    Default RE: PWS on a stand alone machine

    you should be able to install it and start PWS. once you&#039ve installed it however, you will have to reference every url with localhost for it not to connect to your isp and still work.<BR><BR>http://localhost/index.asp

  3. #3
    Mucker Guest

    Default RE: PWS on a stand alone machine - Still Not Worki

    Still doesn&#039t work. I&#039ve installed the Client - Microsoft Family Logon through the Network icon in Control Panel. I&#039ve also assigned a name to the Computer Name field in the Identification tab of the Network Control icon. The name field is Soccer. This allows me to enter http://soccer/ as my home page directory URL. I tried the http://localhost/ but this just acts in the same way as http://soccer/ and I still have to access my ISP before it works. Any other idea&#039s? Thanks for your original reply? I am very grateful.

  4. #4
    vwisneski Guest

    Default ie5.0 and pws

    I have been wrestling with that problem for a LONG time. http://localhost,, editing certain files, nothing seems to work, pws demands that I work online, even when none of the pages require anything from the web. I think that it has to do with the web browser. Somewhere I read that, if you are using IE5.0 and you connect to the internet through a modem and not a LAN, then you cannot use PWS without being connected. Theoretically then, you could tell ie5.0 that you are connecting through a LAN, but that would mean uninstalling everything that says you are using a modem, setting up a fake LAN connection, and then REINSTALLING the modem settings when you want to use the ISP. Even I am not willing to do that. I browse this board often, so please post back if you find something

  5. #5
    Loek Guest

    Default RE: ie5.0 and pws

    I had the same problem while trying to install our website on a laptop for demonstrations. Using IE5, it kept asking for an internet connection when it was not connected to the network. When connected to the network (and therefor to the internet) everything was OK. <BR>So I am afraid that even throwing away all your modem settings won&#039t solve this problem, because our laptop is configured to connect through a LAN.<BR>The only way I managed to work around this is by not using IE5, but by using Netscape4.6.

  6. #6
    Alex K. Guest

    Default RE: ie5.0 and pws

    Check that you have a file called "hosts.sam" installed on your computer (can&#039t remember exactly where it lives, maybe someone can help here). Make a copy of this file and call it "hosts", with no extension, and leave it in the same directory as "hosts.sam". Then add an entry to "hosts" as follows<BR><BR> &#060;insert computer name you&#039d like here&#062;<BR><BR>Save. Then load up IE 5.0. Go to the URL box and enter "http://localhost" or "http://&#060;computer name you chose before&#062;". This works -- I have IE 5.0 with PWS 4.0. Initially it will say something about cannot connect, just click "Stay offline". After this mod, I get no complaints about having to connect to a Web server except when trying to load a non-existent page.<BR><BR>I also connect through a LAN at times and through a modem, and get no problems at all. It would appear to be your setup. Good luck, post back if this doesn&#039t work.

  7. #7
    vwisneski Guest

    Default RE: ie5.0 and pws

    I&#039ve tried modifying the host.sam file ( and renaming it with no extension), but still no luck. I read about that in the NT Options Pack. I think that I did exactly what it said, but it still wouldn&#039t work. I tried and http://&#060;my comp&#039s name&#062; and http://localhost. If it worked for you then I will try again.<BR>Thanks.

  8. #8
    Join Date
    Dec 1969

    Default RE: ie5.0 and pws

    I am running IE5 and PWS without having any problem whatsoever.<BR>The only thing I have to think about is to see that, in the File-menu, the option "Work offline" is NOT checked.<BR>If you work "online" and the computer wants you to connect to your ISP, jst click "work offline" and the go to File-&#062;Work offline and uncheck it. Works for me anyway...

  9. #9
    Neil K Guest

    Default RE: ie5.0 and pws

    So I&#039m not the only one with this prob! I found some stuff that made my setup work - try it and see.<BR>1) go to microsoft main site, search all for "Personal Web Server" or somehow pick up a doc called "Cannot Access Personal Web Server Documents" (RefQ158260)<BR>2) read and curse all the references to IE3 etc<BR>3) Go to the Control Panel/Network and see if you have TCP/IP appearing under the Configuration tab - if not add it. You may also need to add a network client even if your a standalone a machine - I did but I don&#039t really know if it was necessary.<BR>4) Click on TCP/IP then Properties select the WINS and DNS tabs and disable the services.<BR>5) Go to IE5 Tools/Internet Options/Connections tab. Select LAN Settings (I know you&#039re not a LAN but humour me). Tick Use Proxy Server and enter as the address Make sure there is no tick in the By pass Proxy Server for local addresses box. Click OK. In the main part of the Connections tab, I had Never dial radio button selected. OK I had to Dial Up Network from Start/Programmes/Accessories to connect but I can live with that.<BR>6)With PWS started, type in the address bar of IE5<BR>at this point I actually saw the welcome page in IE5 whilst not connected to the internet or a local net.<BR><BR>I haven&#039t got the system to accept my machine&#039s identification (Control Panel/Network/Identification) which is "turkey" yet but everything seems to run ok using localhost or as addresses<BR><BR>Good Luck!!!<BR>Neil K.,<BR>England

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts