Connecting to an Access db -- error

Results 1 to 2 of 2

Thread: Connecting to an Access db -- error

  1. #1
    Join Date
    Dec 1969

    Default Connecting to an Access db -- error

    Hi, <BR><BR>I&#039;ve been running an asp site with an Access db on both PWS and then IIS on a local machine for a few months now with no problems. <BR><BR>Today I uploaded it to the live intranet server where I work. I now get the following error when trying to connect to the db:<BR><BR>------------------<BR><BR>Microsoft OLE DB Provider for ODBC Drivers error &#039;80004005&#039; <BR><BR>[Microsoft][ODBC Microsoft Access 97 Driver] Can&#039;t open database &#039;(unknown)&#039;. It may not be a database that your application recognizes, or the file may be corrupt. <BR><BR>/Services/Corporate/Countyit/cit/AppSupport/deebee1/search_info.asp, line 6 <BR><BR>----------------<BR><BR>Here is the offending line(s) in my code, where I connect to the db:<BR><BR>&#039;Connection<BR>Dim oConn<BR>Set oConn = Server.CreateObject("ADODB.Connection")<BR>oConn.O pen("DRIVER={Microsoft Access Driver (*.mdb)}; DBQ=" & Server.MapPath("dbinv.mdb"))<BR><BR>---------------<BR><BR>I&#039;ve not moved the asp pages relative to the db, it&#039;s exactly the same as when running fine on my local machine. <BR><BR>Any ideas?<BR><BR>Thanks<BR><BR>Jim

  2. #2
    Join Date
    Dec 1969

    Default RE: Connecting to an Access db -- error

    1. maybe it I corrupted. try uploading a decent copy.<BR>2. make sure the MDAC on the server is up to date.<BR><BR>j<BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts