ADODB.Parameters error ' 800a0cc1'

Results 1 to 5 of 5

Thread: ADODB.Parameters error ' 800a0cc1'

  1. #1
    Join Date
    Dec 1969
    Posts
    73

    Default ADODB.Parameters error ' 800a0cc1'

    I am stuck in this ASP project and thought may be you can help. <BR><BR>I am getting following error: <BR><BR>"<BR>ADODB.Parameters error &#039 800a0cc1&#039 <BR>ADO could not find the object in the collection corresponding to the name or ordinal reference requested by the application. <BR>/north/proc2.asp, line 30 <BR>"<BR><BR>Line 30: cmd.parameters(0)= Request("part1")<BR><BR>Ok, i have access database with table "Cams" and query "CamsQ", everything is text and i am not sure why I am getting his error :((( HELP, CamsQ work fine in access database and SQL query is : <BR><BR>PARAMETERS [Part1] Text, [Cams1] Text;<BR>SELECT Cams.part, Cams.cams<BR>FROM Cams<BR>WHERE Cams.part = [Part1] or Cams.cams = [Cams1];<BR><BR><BR>I am attaching the code too, <BR><BR> Part # :&#060;%=Request.Form("part1")&#037;&#062; <BR><BR> Cams # :&#060;%=Request.Form("cams1")&#037;&#062; &#060;/font><BR>&#060;%<BR>&#039On Error Resume Next<BR>Dim con<BR>Dim prm<BR><BR>Const adCmdStoredProc = 4 <BR>&#039I am not sure if this is problem<BR>Const adInteger = 3<BR><BR>Set con = Server.CreateObject("ADODB.Connection")<BR>con.Ope n "SearchQ"<BR><BR>Set cmd = Server.CreateObject("ADODB.Command")<BR>Set cmd.ActiveConnection = con<BR>cmd.CommandText = "CamsQ"<BR>cmd.CommandType = adCmdStoredProc<BR><BR>&#039but code get stuck on following line<BR>cmd.parameters(0)= Request("part1") &#039part1 is text <BR>cmd.parameters(1)= Request("cams1") &#039cams1 is text<BR>set rs = cmd.Execute()<BR>&#037;&#062;

  2. #2
    Ian Stallings Guest

    Default RE: ADODB.Parameters error ' 800a0cc1'

    from what I can tell , maybe someone can verify this,<BR>you are using Request("parts1") when it should be<BR>Request.Form("parts1")<BR><BR>hope this helps.

  3. #3
    Join Date
    Dec 1969
    Posts
    73

    Default RE: ADODB.Parameters error ' 800a0cc1'

    I tried that too :((.. All I am doing is running the query CamsQ which is in MS access using ASP.<BR><BR>Do you know any other way to do this ? <BR><BR>Farhan

  4. #4
    Join Date
    Dec 1969
    Posts
    511

    Default RE: ADODB.Parameters error ' 800a0cc1'

    Why not use an SQL string to perform the query instead?<BR><BR>Pete


  5. #5
    Join Date
    Dec 1969
    Posts
    73

    Default RE: ADODB.Parameters error ' 800a0cc1'

    I tried that too :((

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •