Hi! (kinda need this solved ASAP)<BR><BR>If you have any suggestions or insights as to how the AOL browser for Macs (any Mac - we&#039ve tested on G3&#039s, G4&#039s, and their predecessors) submit forms, I would be very glad to hear a response. I&#039m at the point where I&#039m willing to try anything. If you can solve the problem, you&#039re my lifesaver!!!<BR><BR>I have set up a form ("post") called search.asp to search a database. The collected form data is then dumped onto a results.asp page to display the results of the search. Everything works perfectly on IE and Netscape on PC&#039s and on Netscape on Macs. However, on AOL for Macs, search.asp contacts the server and receives the results.asp but sits at search.asp. The results page does not display at all!<BR><BR>I&#039ve tried debugging, thinking something is wrong with the server-side VBscript on the results.asp page, but the same problem occurs. I&#039ve simplified the results.asp page to straight HTML. I&#039ve tried moving the results.asp page to be the default page of a new directory. I&#039ve tried several variants for the action call on the form (ie: "action=results.asp", "action=http://www.site.com/directory/results.asp", "action=http://www.site.com/directory", "action=http://www.site.com/directory/"). I&#039ve tried converting a simplified version of results.asp to results.html and loaded that page straight from the location bar. I&#039ve saved a successful view of results.asp as a .html file and tried opening that results.html file. The results.html file reads perfectly.<BR><BR>I&#039m guessing there&#039s something I&#039m not seeing in regards to the way the AOL browser is submitting the form data and/or reading the form.<BR><BR>I cannot seem to get this to work. I&#039m hoping I haven&#039t overlooked something silly but I&#039m willing to hear any opinions.<BR><BR>Thanks!