W2K Pro IIS Database Problem...

Results 1 to 2 of 2

Thread: W2K Pro IIS Database Problem...

  1. #1
    Join Date
    Dec 1969

    Default W2K Pro IIS Database Problem...

    I just upgraded my computer from win98 to W2K Pro. Since Pro automatically comes with IIS, i&#039;m trying to run it on my machine. Everything works fine with the ASP, however when i try to access my database w/ the ASP it won&#039;t work. Below is a copy of the error i get and the code it says is causing it (btw it&#039;s an access db):<BR><BR><BR>Error Type:<BR>Provider (0x80004005)<BR>Unspecified error<BR>/Active_Pages/index.asp, line 4<BR><BR><BR><BR>Path = Server.MapPath("/")<BR>dsc = "DRIVER={Microsoft Access Driver (*.mdb)}; DBQ=" & Path & "ArcDBA2K
    ecord.mdb"<BR>Set connection = Server.CreateObject("ADODB.Connection")<BR>connect ion.Open dsc<BR>Set members = Server.CreateObject("ADODB.Recordset")<BR>Set orders = Server.CreateObject("ADODB.Recordset")<BR>Set calls = Server.CreateObject("ADODB.Recordset")<BR><BR>The problem is when the connection tries to open. No problem creating the object, just opening it, or doing anything with it. Suggestions?<BR><BR>- Matt

  2. #2
    Join Date
    Dec 1969

    Default RE: W2K Pro IIS Database Problem...

    Matt, <BR> The problem could be in the connection string you are using. Try using a connection string similar to the following:<BR><BR><BR>Set conn = Server.CreateObject("ADODB.Connection")<BR>conn.op en "Provider=Microsoft.Jet.OLEDB.4.0;"&_<BR> "Data Source = d:arcdba2k
    ecord.mdb;" &_<BR> "Persist Security Info = False"<BR><BR>you may have to adjust the path to point to the correct location of your database though.<BR><BR>mj<BR>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts